Deprecation reminder: Migrate all scripts away from OAuthConfig before June 26th, 2015

G Suite News

Google_Apps_ScriptOAuth is the de facto standard for authorization today and used by most modern APIs. To assist with connecting Apps Script to OAuth-protected APIs, we recently created two new open source libraries: OAuth1 for Apps Script and OAuth2 for Apps Script. These libraries replace and extend the capabilities of the UrlFetch service’s limited OAuthConfig class.

All Google APIs (Google Calendar, Google Drive, etc.) stopped supporting OAuth1 (and by extension OAuthConfig) on April 20th, 2015. Scripts using these APIs should have been migrated to the OAuth2 for Apps Script library or the API’s equivalent Advanced Service.

On June 26th, 2015, we will go one step further and shut down the OAuthConfig class completely. This means that if you have scripts that still use OAuthConfig to connect to APIs, you will need to update your code to use the OAuth1 for Apps Script library before June 26th, 2015.

Release track:
Rapid release and Scheduled release

 

I would like to receive more information